hdu 1266

杭电2010和2011级同学如何加入ACM集训队?

Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2308    Accepted Submission(s): 1071


Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
 

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 

Output
For each test case, you should output its reverse number, one case per line.
 

Sample Input
   
   
   
   
3 12 -12 1200
 

Sample Output
   
   
   
   
21 -21 2100
 
#include<iostream>  
#include<string>  
using namespace std;  
  
int main()//定义了两个n  
{  
    int n;  
    cin>>n;  
    while(n--)  
    {  
        string s;  
        int a=0,i,m;  
        cin>>s;  
        if(s[0]=='-')cout<<"-";  
        i=s.length()-1;  
        while(s[i]=='0'&&i>0)i--;  
        m=s.length()-i-1;  
        while(i>0)  
        {  
            cout<<s[i];  
            i--;  
        }  
        if(s[0]>='0'&&s[0]<='9')  
        {  
            cout<<s[0];  
        }  
        while(m--)  
            cout<<"0";  
        cout<<endl;  
    }  
  
    return 0;  
}

你可能感兴趣的:(String,File,Integer,input,each,output)