AreYouBusy
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2510 Accepted Submission(s): 940
Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1
3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1
1 1
1 0
2 1
5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10
Sample Output
Author
hphp
Source
2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU
解题报告:有3种转移方式。一种至少选一个,一种至多选一个,一种随意。
状态转移弄清楚,代码还是很容易写的。注意的问题是,w可能是0,所以判断的顺序要注意下,否则会错误的加上两次v。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[111][111];
int n,V;
int main()
{
while(~scanf("%d%d",&n,&V))
{
memset(dp[0],0,sizeof(dp[0]));
for(int i=1;i<=n;i++)
{
memset(dp[i],0x80,sizeof(dp[i]));
int m,tp;
scanf("%d%d",&m,&tp);
while(m--)
{
int w,v;
scanf("%d%d",&w,&v);
for(int j=V;j>=w;j--)
{
if(tp!=0) dp[i][j]=max(dp[i][j],dp[i-1][j]);
if(tp!=1) dp[i][j]=max(dp[i][j],dp[i][j-w]+v);
dp[i][j]=max(dp[i][j],dp[i-1][j-w]+v);
}
if(tp!=0) for(int j=w-1;j>=0;j--)
dp[i][j]=max(dp[i][j],dp[i-1][j]);
}
}
dp[n][V]=max(dp[n][V],-1);
printf("%d\n",dp[n][V]);
}
}