11-2 员工有薪水了(拓展)

/*
* 作    者: 霍雨佳
* 完成日期:2014 年5月13日
* 版 本 号:v1.0
* 问题描述:定义一个名为CPerson的类,有以下私有成员:姓名、身份证号、性别和年龄,成员函数:构造函数、析构函数、输出信息的函数。
*           并在此基础上派生出CEmployee类,派生类CEmployee增加了两个新的数据成员,分别用于表示部门和薪水。
* 样例输入:
* 样例输出:
* 项目要求:要求派生类CEmployee的构造函数显示调用基类CPerson的构造函数,并为派生类CEmployee定义析构函数,定义输出信息的函数。
* 项目拓展要求:字符串除了用C++扩充的string类型外,按C语言的传统,还用char *表示。将类声明中的string全部改为char *后,重新写一遍程序(此时的区别是,类中有指针成员,构造和析构函数需要考虑深复制的问题了。)
*/
#include <iostream>
#include <string.h>
using namespace std;
class CPerson
{
protected:
	char *m_szName;
	char *m_szId;
	int m_nSex;//0:women,1:man
	int m_nAge;
public:
	CPerson(char *name,char *id,int sex,int age);
	void Show1();
	~CPerson();
};
CPerson::CPerson(char *name,char *id,int sex,int age)
{
    m_szName=new char[strlen(name)+1];
    strcpy(m_szName,name);
    m_szId=new char[strlen(id)+1];
    strcpy(m_szId,id);
    m_nSex=sex;
    m_nAge=age;
}
void CPerson::Show1()
{
   cout<<"name:"<<m_szName<<endl;
    cout<<"id:  "<<m_szId<<endl;
     cout<<"sex(0:women,1:man):"<<m_nSex<<endl;
    cout<<"age: "<<m_nAge<<endl;
}
CPerson::~CPerson()
	{
	    delete[]m_szName;
	    delete[]m_szId;
	}
class CEmployee:public CPerson
{
private:
	char *m_szDepartment;
	float m_Salary;
public:
	CEmployee(char *name,char *id,int sex,int age,char *department,float salary);
	void Show2();
	~CEmployee();
};
CEmployee::CEmployee(char *name,char *id,int sex,int age,char *department,float salary):CPerson(name,id,sex,age)
{
   m_szDepartment=new char[strlen(department)+1];
    strcpy(m_szDepartment,department);
    m_Salary=salary;
}
void CEmployee::Show2()
{
    Show1();
   cout<<"department:"<<m_szDepartment<<endl;
    cout<<"salary:   "<<m_Salary<<endl;
}
CEmployee::~CEmployee()
	{
	    delete[]m_szDepartment;
	}
int main()
{
	char name[10],id[19],department[10];
	int sex,age;
	float salary;
	cout<<"input employee's name,id,sex(0:women,1:man),age,department,salary:\n";
	cin>>name>>id>>sex>>age>>department>>salary;
	CEmployee employee1(name,id,sex,age,department,salary);
	employee1.Show2();
	return 0;
}


运行结果:

  对于 char *表示 的运用不够熟练……

你可能感兴趣的:(11-2 员工有薪水了(拓展))