hdu1622二叉树的建立

Trees on the level

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 192    Accepted Submission(s): 74


Problem Description
Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree


is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

 

Input
The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

 

Output
For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed
 

Sample Input
    
    
    
    
(11,LL) (7,LLL) (8,R)(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()(3,L) (4,R) ()
 

Sample Output
    
    
    
    
5 4 8 11 13 4 7 2 1not complete
 
#include<stdio.h>
#include<malloc.h>
#include<string.h>
typedef struct haha
{
    int num;
    struct haha *left;
    struct haha *right;
}node;
node *queue[300];
int ans[300];
int main()
{
    int i,d,n,flag,head,tail,cnt,count;
    node *root,*temp1,*temp2;
    char s[10000];
    while(scanf("%s",s)!=EOF)
    {
        flag=1;
        d=strlen(s);
        // puts(s);
        if(d==2&&s[0]=='('&&s[1]==')') {printf("not complete\n");continue;}
        root=(node *)malloc(sizeof(node));
        root->left=NULL;root->right=NULL;
        root->num=-1; temp1=root;
        for(i=0;i<d;i++)
        {
            if(s[i]=='L')
            {
                temp2=(node *)malloc(sizeof(node));
                temp2->num=-1;
                temp2->right=temp2->left=NULL;
                temp1->left=temp2;
                temp1=temp2;
            }
            else if(s[i]=='R')
            {
                temp2=(node *)malloc(sizeof(node));
                temp2->num=-1;
                temp2->left=temp2->right=NULL;
                temp1->right=temp2;
                temp1=temp2;
            }
        }
        if(s[1]==',') flag=0;
        if(flag)
        {
            sscanf(s+1,"%d",&n);
            if(temp1->num==-1)
            {
                temp1->num=n;
            }
            else flag=0;
        }
        cnt=1;
        while(1)
        {
            scanf("%s",s);
            cnt++;
            d=strlen(s);
            if(d==2&&s[0]=='('&&s[1]==')')  break;
            temp1=root;
            if(flag)
                for(i=0;i<d;i++)
                {
                    if(s[i]=='L')
                    {
                        if(temp1->left!=NULL) temp1=temp1->left;//注意 已经建立起来的路不要重新建
                        else
                        {
                            temp2=(node *)malloc(sizeof(node));;
                            temp2->num=-1;
                            temp2->right=temp2->left=NULL;
                            temp1->left=temp2;
                            temp1=temp2;
                        }
                    }
                    else if(s[i]=='R')
                    {
                        if(temp1->right!=NULL) temp1=temp1->right;
                        else
                        {
                            temp2=(node *)malloc(sizeof(node));;
                            temp2->num=-1;
                            temp2->left=temp2->right=NULL;
                            temp1->right=temp2;
                            temp1=temp2;
                        }
                    }
                }
                if(s[1]==',') flag=0;
                if(flag)
                {
                    sscanf(s+1,"%d",&n);
                    if(temp1->num==-1)
                    {
                        temp1->num=n;
                    }
                    else flag=0;
                }
        }
        // printf("why");
        if(root->num==-1)  flag=0;
        head=1;tail=2;
        queue[1]=root;count=0;
        if(flag)
            while(head<tail)
            {
                temp1=queue[head];
                if(temp1->num!=-1) {ans[count++]=temp1->num;}
                if(temp1->left!=NULL&&temp1->left->num!=-1)//还要保证temp1->left->num!=-1  也就是说要找某个数 在找的路径中不能有没有赋值的路
                    queue[tail++]=temp1->left;
                if(temp1->right!=NULL&&temp1->right->num!=-1)
                    queue[tail++]=temp1->right;
                head++;
            }
            // printf("cnt=%d count=%d",cnt,count);
            if(count==cnt-1&&flag)
            {
                for(i=0;i<count-1;i++)
                    printf("%d ",ans[i]);
                printf("%d\n",ans[count-1]);
            }
            else printf("not complete\n");
 }
 return 0;
}
/*模拟建树 +  BFS狂扫*/

你可能感兴趣的:(hdu1622二叉树的建立)