HDU 1686 Oulipo(KMP算法 字符串匹配)

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
   
   
   
   
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
   
   
   
   
1 3 0
 
/************************************************************************/

题意:t组测试样例,每组给你一个字符串A和字符串B,问字符串B中有多少个像字符串A这样的子串。

解题思路:此题考查的是KMP算法,即字符串匹配算法,其复杂度是O(n+m),关于KMP算法,可以参考字符串匹配的KMP算法

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<stdlib.h>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
using namespace std;
const int N = 10001;
const int inf = 2147483647;
const int mod = 2009;
char s2[N],s[N*100];
int n[N];
void getnext()
{
    int i=0,j=-1,l=strlen(s2);
    n[0]=-1;
    while(i<l)
    {
        if(j==-1||s2[i]==s2[j])
        {
            i++;j++;
            if(s2[i]==s2[j])
                n[i]=n[j];
            else
                n[i]=j;
        }
        else
            j=n[j];
    }
}
int kmp()
{
    getnext();
    int i=0,j=0,k=0,len=strlen(s),l=strlen(s2);
    while(i<len)
    {
        if(j==-1||s[i]==s2[j])
            i++,j++;
        else
            j=n[j];
        if(j==l)
            k++,j=n[j];
    }
    return k;
}
int main()
{
    int t;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        gets(s2);gets(s);
        memset(n,0,sizeof(n));
        printf("%d\n",kmp());
    }
    return 0;
}

菜鸟成长记


你可能感兴趣的:(算法,KMP,ACM)