杭电1058 数学题 Humble Numbers

     这道题真是纠结,昨天下午想,昨天晚上想,今天上午想,想了各种各样的方法,都否决了。明明知道是打表,却一直在纠结到底该怎样打表。今天上午终于是过了。。。。被虐了。具体来说,第一个元素肯定是1,接下来的元素,开始一个一个的试探,分别乘2,乘3,乘5,乘7,哪个小取哪个,乘过之后,p2,p3,p5,p7的值还要改变一下。。。其实就是一个光搜的过程,,,,题目:

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7438    Accepted Submission(s): 3245


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
   
   
   
   
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
   
   
   
   
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;
long long min(long long a,long long b,long long c,long long d){
 long long x=a<b?a:b;
  long long y=c<d?c:d;
  return x<y?x:y;
}
int main(){
	//freopen("4.txt","r",stdin);
  long long num[10005];
  long long p2,p3,p5,p7;
  p2=p3=p5=p7=1;
  memset(num,0,sizeof(num));
  num[1]=1;
  int i=1;
  while(num[i]<=2000000000){
    num[++i]=min(num[p2]*2,num[p3]*3,num[p5]*5,num[p7]*7);
	if(num[i]==num[p2]*2) p2++;
	if(num[i]==num[p3]*3) p3++;
	if(num[i]==num[p5]*5) p5++;
	if(num[i]==num[p7]*7) p7++;
	//i++;
  }
  int n;
  while(scanf("%d",&n)&&n){
	string ss;
	if(n%10==1&&n%100!=11)
		printf("The %dst humble number is %lld.\n",n,num[n]);
	else if(n%10==2&&n%100!=12)
		printf("The %dnd humble number is %lld.\n",n,num[n]);
	else if(n%10==3&&n%100!=13)
		printf("The %drd humble number is %lld.\n",n,num[n]);
	else 
		printf("The %dth humble number is %lld.\n",n,num[n]);
   
  }
  return 0;
}


你可能感兴趣的:(杭电1058 数学题 Humble Numbers)