hdu2838之树状数组

Cow Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2086    Accepted Submission(s): 644


Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.
 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
   
   
   
   
3 2 3 1
 

Sample Output
   
   
   
   
7
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef __int64 LL;
using namespace std;

const int MAX=100000+10;
int n;
LL c[MAX],a[MAX];

int lowbit(int x){
	return x&(-x);
}

void Update(int x,int d){
	while(x<=n){
		c[x]+=d;
		x+=lowbit(x);
	}
}

int Query(int x){
	int sum=0;
	while(x>0){
		sum+=c[x];
		x-=lowbit(x);
	}
	return sum;
}

int main(){
	while(~scanf("%d",&n)){
		for(int i=1;i<=n;++i)scanf("%d",a+i);
		memset(c,0,sizeof c);
		LL sum=0;
		for(int i=1;i<=n;++i){//i需要与前面多少个数交换 
			LL num=Query(a[i]);
			sum+=(i-1-num)*a[i];
			Update(a[i],1);
		}
		memset(c,0,sizeof c);
		for(int i=n;i>=1;--i){//i需要与后面多少个数交换 
			LL num=Query(a[i]-1);
			sum+=num*a[i];
			Update(a[i],1);
		}
		printf("%I64d\n",sum);
	}
	return 0;
}

你可能感兴趣的:(hdu2838之树状数组)