HDOJ 1034 Candy Sharing Game(模拟)



Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4439    Accepted Submission(s): 2709


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
   
   
   
   
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
   
   
   
   
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 

题意:看懂题意很关键啊,英语瞎真是跪哭。 有N个学生围成环坐在一起,开始的时候,每人手中都有偶数粒糖果,在哨声响起时同时将自己手中拿出一半给右边的同学(注意是n个人同时给,就是这儿没看懂),结束后,手中糖果是奇数的会从老师那儿得到一粒变成偶数。当所有同学手中的糖果数都相等时,游戏结束。给出初始状态,问游戏结束要吹几次哨子,最终同学们手中的糖果是多少。

很简单,按照题目说的模拟一下游戏过程就可以了。

代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int a[10000],b[10000];
int main()
{
	int n,i,ans,j;
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;++i)
			scanf("%d",&a[i]);
		ans=0;
		while(1)
		{
			memset(b,0,sizeof(b));
			for(i=0;i<n;++i)
				a[i]/=2;
			for(i=0;i<n;++i)
			{
				if(i==n-1)
					b[0]=a[0]+a[n-1];
				else
					b[i+1]=a[i+1]+a[i];
			}
			for(i=0;i<n;++i)
			{
				if(b[i]&1)
					b[i]++;
				a[i]=b[i];
			}
			int sign=1;
			for(i=0;i<n;++i)
			{
				for(j=0;j<n;++j)
				{
					if(a[i]!=a[j])
					{
						sign=0;
						break;
					}
				}
				if(!sign)
					break;
			}
			ans++;
			if(sign)
				break;
		}
		printf("%d %d\n",ans,a[0]);
	}
	return 0; 
}



你可能感兴趣的:(HDOJ 1034 Candy Sharing Game(模拟))