hdu 2896 病毒侵袭(AC自动机)

病毒侵袭

                                                                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

Sample Input
   
   
   
   
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output
   
   
   
   
web 1: 1 2 3 total: 1
 
分析:解法很容易想到。用给出的模式串构建AC自动机,然后用web主串去匹配就行了。
要注意一点,一个病毒可能会在一个web网站中出现多次,例如病毒为ab,网站为ababab,其实这只包含了一种病毒。所以我用了set来存储病毒编号。
#include<cstdio>
#include<set>
using namespace std;

const int kind = 128; //有多少种字符
const int N = 505;
const int M = 10005;
struct node
{
    node *next[kind];
    node *fail;
    int id;//病毒编号
    int cnt; //是不是病毒单词的结尾
    node() {
        for(int i = 0; i < kind; i++)
            next[i] = NULL;
        cnt = 0; //0表示不是单词结尾
        fail = NULL;
    }
}*q[200*N];
node *root;
int head, tail;
char web[M];
char vir[205];
set<int> id_set;  //记录每个网站的病毒编号,因为一个病毒可能会在一个网站出现多次,set可以直接去重
set<int> ::iterator it;

void Insert(char *str, int id)
{
    node *p = root;
    int i = 0, index;
    while(str[i]) {
        index = str[i] - ' ';
        if(p->next[index] == NULL)
            p->next[index] = new node();
        p = p->next[index];
        i++;
    }
    p->cnt++;
    p->id = id;
}
void build_ac_automation(node *root)
{
    root->fail = NULL;
    q[tail++] = root;
    node *p = NULL;
    while(head < tail) {
        node *temp = q[head++];
        for(int i = 0; i < kind; i++) {
            if(temp->next[i] != NULL) {
                if(temp == root) temp->next[i]->fail = root;
                else {
                    p = temp->fail;
                    while(p != NULL) {
                        if(p->next[i] != NULL) {
                            temp->next[i]->fail = p->next[i];
                            break;
                        }
                        p = p->fail;
                    }
                    if(p == NULL) temp->next[i]->fail = root;
                }
                q[tail++] = temp->next[i];
            }
        }
    }
}
int Query(char *str)
{
    id_set.clear();
    int i = 0, index;
    node *p = root;
    while(str[i]) {
        index = str[i] - ' ';
        while(p->next[index] == NULL && p != root) p = p->fail;
        p = p->next[index];
        if(p == NULL) p = root;
        node *temp = p;
        while(temp != root && temp->cnt > 0) {
            id_set.insert(temp->id);
            temp = temp->fail;
        }
        i++;
    }
    return id_set.size();
}

int main()
{
    int m, n;
    while(~scanf("%d",&n)) {
        int total = 0;
        head = tail = 0;
        root = new node();
      for(int i = 1; i <= n; i++) {
            scanf("%s", vir);
            Insert(vir, i);
        }
        build_ac_automation(root);
        scanf("%d",&m);
        for(int i = 1; i <= m; i++){
            scanf("%s",web);
            int s = Query(web);
            if(s) {
                total++;
                printf("web %d:", i);
                for(it = id_set.begin(); it != id_set.end(); it++)
                    printf(" %d", *it);
                printf("\n");
            }
        }
        printf("total: %d\n", total);
    }
    return 0;
}


你可能感兴趣的:(hdu 2896 病毒侵袭(AC自动机))