UVa 10252 Common Permutation (water ver.)

10252 - Common Permutation

Time limit: 3.000 seconds 

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1193

Given two strings of lowercase letters, a and b, print the longest string x of lowercase letters such that there is a permutation of x that is a subsequence of a and there is a permutation of x that is a subsequence of b.

 

Input

Input file contains several lines of input. Consecutive two lines make a set of input. That means in the input file line 1 and 2 is a set of input, line 3 and 4 is a set of input and so on. The first line of a pair contains a and the second contains b. Each string is on a separate line and consists of at most 1000 lowercase letters.

 

Output

For each set of input, output a line containing x. If several x satisfy the criteria above, choose the first one in alphabetical order.

 

Sample Input:

pretty
women
walking
down
the
street
 

Sample Output:

e

nw

et


水。


完整代码:

/*0.019s*/

#include<bits/stdc++.h>
using namespace std;

char a[1005], b[1005], ans[1005];
bool vis[1005];

void solve(char* a, char* b)
{
	int lena = strlen(a), lenb = strlen(b), i, j, c = 0;
	memset(vis, 0, sizeof(vis));
	for (i = 0; i < lena; ++i)
		for (j = 0; j < lenb; ++j)
		{
			if (!vis[j] && a[i] == b[j])
			{
				ans[c++] = a[i];
				vis[j] = true;
				break;
			}
		}
	ans[c] = 0;
	sort(ans, ans + c);
	puts(ans);
}

int main()
{
	while (gets(a))
	{
		gets(b);
		if (strlen(a) < strlen(b)) solve(a, b);
		else solve(b, a);
	}
	return 0;
}

你可能感兴趣的:(C++,ACM,uva)