YT14-HDU-棋盘与骨牌块

Problem Description

Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.

Input

There are multiple test cases in the input file.
First line contain the number of cases T ($T \leq 10000$). 
In the next T lines contain T cases , Each case has two integers n and k. ($1 \leq n, k \leq 100$)

Output

Print the maximum number of chessboard squares tiled.

Sample Input

2
6 3
5 3

Sample Output

36
24
代码如下:

#include<iostream>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,k,m;
        cin>>n>>k;
        if(n<k)
        {
            cout<<"0"<<endl;
            continue;
        }
        m=n%k;
        if(m>k/2)
             cout<<n*n-(k-m)*(k-m)<<endl;
        else
            cout<<n*n-m*m<<endl;
    }
    return 0;
}

运行结果:





你可能感兴趣的:(编程,C++,数据,namespace,iostream)