POJ 2104(K-th Number-区间第k大-主席树)

K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 31790   Accepted: 9838
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion


这题是主席树裸题。

但是我却狂T——

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#include<cmath>
#include<cctype>
#include<map>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define RepD(i,n) for(int i=n;i>=0;i--)
#define MAXN (100000+10)
#define MAXM (5000+10)
int n,m,a[MAXN],a2[MAXN];
struct node
{
	node *ch[2];
	int a,siz;
	node(){ch[0]=ch[1]=NULL;siz=a=0;}
	node(node *_ch0,node *_ch1,int _a,int _siz):a(_a),siz(_siz){ch[0]=_ch0,ch[1]=_ch1;}
	void update()
	{
		siz=a;
		if (ch[0]) siz+=ch[0]->siz;
		if (ch[1]) siz+=ch[1]->siz;
	}
}*null=new node(),*root[MAXN]={NULL};
void make_node(node *&y,node *&x,int l,int r,int t)
{
	if (x==NULL) x=null;
	y=new node();
	int m=(l+r)>>1;
	if (l==r)
	{
		*y=*x;
		y->siz++;y->a++;
		return;
	}
	if (t<=a2[m]) 
	{
		make_node(y->ch[0],x->ch[0],l,m,t);
		y->ch[1]=x->ch[1];
		y->update();
	}
	else
	{
		make_node(y->ch[1],x->ch[1],m+1,r,t);
		y->ch[0]=x->ch[0];
		y->update();
	}
}
void find(node *&x1,node *&x2,int l,int r,int k)
{
	if (x1==NULL) x1=null;
	if (x2==NULL) x2=null;
	if (l==r) {printf("%d\n",a2[l]);return;}
	int m=(l+r)>>1;
	int ls=0;
	if (x2->ch[0]) ls+=x2->ch[0]->siz;
	if (x1->ch[0]) ls-=x1->ch[0]->siz;
	
	if (ls>=k) find(x1->ch[0],x2->ch[0],l,m,k);
	else find(x1->ch[1],x2->ch[1],m+1,r,k-ls);
}
int main()
{
	freopen("poj2104.in","r",stdin);
	null->ch[0]=null; null->ch[1]=null;
	scanf("%d%d",&n,&m);
	For(i,n) scanf("%d",&a[i]),a2[i]=a[i]; 
	sort(a2+1,a2+1+n);
	int size=unique(a2+1,a2+1+n)-(a2+1);
	For(i,n)
	{
		make_node(root[i],root[i-1],1,size,a[i]);
	}
	For(i,m)
	{
		int l,r,k;
		scanf("%d%d%d",&l,&r,&k);
		find(root[l-1],root[r],1,size,k);
	}	
	return 0;
}

于是在柯老师的教导下,我发现致使我狂T的因素是不断new 结点,于是我将结点事先用数组开好。

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#include<cmath>
#include<cctype>
#include<map>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define RepD(i,n) for(int i=n;i>=0;i--)
#define MAXN (200000+10)
#define MAXM (200000+10)
int n,m,a[MAXN],a2[MAXN];
struct node
{
	node *ch[2];
	int a,siz;
	node(){ch[0]=ch[1]=NULL;siz=a=0;}
	void update()
	{
		siz=a;
		if (ch[0]) siz+=ch[0]->siz;
		if (ch[1]) siz+=ch[1]->siz;
	}
}*null=new node(),*root[MAXN]={NULL},q[MAXN*9];
int q_s;
void make_node(node *&y,node *&x,int l,int r,int t)
{
	if (x==NULL) x=null;
	y=&q[++q_s];
	*y=node();
	int m=(l+r)>>1;
	if (l==r)
	{
		*y=*x;
		y->siz++;y->a++;
		return;
	}
	if (t<=a2[m]) 
	{
		make_node(y->ch[0],x->ch[0],l,m,t);
		y->ch[1]=x->ch[1];
		y->update();
	}
	else
	{
		make_node(y->ch[1],x->ch[1],m+1,r,t);
		y->ch[0]=x->ch[0];
		y->update();
	}
}
void find(node *&x1,node *&x2,int l,int r,int k)
{
	if (x1==NULL) x1=null;
	if (x2==NULL) x2=null;
	if (l==r) {printf("%d\n",a2[l]);return;}
	int m=(l+r)>>1;
	int ls=0;
	if (x2->ch[0]) ls+=x2->ch[0]->siz;
	if (x1->ch[0]) ls-=x1->ch[0]->siz;
	if (ls>=k) find(x1->ch[0],x2->ch[0],l,m,k);
	else find(x1->ch[1],x2->ch[1],m+1,r,k-ls);
}
int main()
{
	//freopen("hdu2665.in","r",stdin);
	null->ch[0]=null; null->ch[1]=null;
	q_s=0;
	scanf("%d%d",&n,&m);
	For(i,n) scanf("%d",&a[i]),a2[i]=a[i]; 
	sort(a2+1,a2+1+n);
	int size=unique(a2+1,a2+1+n)-(a2+1);
	For(i,n)
	{
		make_node(root[i],root[i-1],1,size,a[i]);
	}
	For(i,m)
	{
		int l,r,k;
		scanf("%d%d%d",&l,&r,&k);
		find(root[l-1],root[r],1,size,k);
	}	
return 0;
}

终于过了……伤不起……

最后再来一份 用类似划分树 的分块思想 求静态第k大的



#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
#include<iomanip> 
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define ForkD(i,k,n) for(int i=n;i>=k;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=Pre[x];p;p=Next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=Next[p])  
#define Lson (o<<1)
#define Rson ((o<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (100000007)
#define pb push_back
#define mp make_pair 
#define fi first
#define se second
#define vi vector<int> 
#define pi pair<int,int>
#define SI(a) ((a).size())
typedef long long ll;
typedef unsigned long long ull;
int read()
{
	int x=0,f=1; char ch=getchar();
	while(!isdigit(ch)) {if (ch=='-') f=-1; ch=getchar();}
	while(isdigit(ch)) { x=x*10+ch-'0'; ch=getchar();}
	return x*f;
} 
#define MAXN (200000+10)
ll a[20][MAXN];
int list[MAXN];
const int Maxj = 18;
int work(int j,int l,int r,int c) {
	if (a[j][r]<=c) return r-l+1;
	if (a[j][l]>c) return 0;
	int p=upper_bound(a[j]+l,a[j]+r+1,c)-a[j];	
	return p-l;
}

int main()
{
//	freopen("poj2104.in","r",stdin);
//	freopen(".out","w",stdout);

	int n=read(),m=read();
	For(i,n) a[0][i]=read();
		
	for(int j=1;j<=Maxj;j++) {
		int step = 1<<j;
		For(i,n) a[j][i]=a[0][i];
		for(int i=1 ; i+step-1 <= n ; i += step )
		{
			sort(a[j]+i,a[j]+i+step);
		}
	}
	
	while(m--) {
		int L=read(),R=read(),k=read();
		
		int blo=0;
		
		int l=-1000000000,r=1000000000,ans=r;
		while (l<=r)
		{
			int m=(l+r)>>1;
			int tot=0;
			for(int i=L;i<=R;) {
				int j=Maxj;
				while (i + (1<<j) - 1 > R ) j--;
				while (i%(1<<j)!=1 && j)
					j--;
				tot+=work(j,i,i+(1<<j)-1,m);
				i+=(1<<j);
			}
			if (tot<k) l=m+1;
			else ans=m,r=m-1;
		}
		printf("%d\n",ans);
	}




	return 0;
}







你可能感兴趣的:(POJ 2104(K-th Number-区间第k大-主席树))