hdu2614之简单搜索

Beat

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 379    Accepted Submission(s): 247


Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem. 
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
 

Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
 

Output
For each test case output the maximum number of problem zty can solved.


 

Sample Input
   
   
   
   
3 0 0 0 1 0 1 1 0 0 3 0 2 2 1 0 1 1 1 0 5 0 1 2 3 1 0 0 2 3 1 0 0 0 3 1 0 0 0 0 2 0 0 0 0 0
 

Sample Output
   
   
   
   
3 2 4
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=15+10;
int s[MAX][MAX],sum,n;
bool mark[MAX];

void dfs(int id,int num,int sorce){
	for(int i=0;i<n;++i){
		if(mark[i] || s[id][i]<sorce)continue;
		mark[i]=true;
		dfs(i,num+1,s[id][i]);
		mark[i]=false;
	}
	sum=max(sum,num);
}

int main(){
	while(cin>>n){
		for(int i=0;i<n;++i){
			for(int j=0;j<n;++j)cin>>s[i][j];
		}
		memset(mark,false,sizeof mark);
		sum=0;
		mark[0]=true;
		dfs(0,1,0);
		cout<<sum<<endl;
	}
	return 0;
}


你可能感兴趣的:(hdu2614之简单搜索)