UVa 543 Goldbach's Conjecture (素数&哥德巴赫猜想)

543 - Goldbach's Conjecture

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=484

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every number greater than 2 can be written as the sum of three prime numbers.

Goldbach cwas considering 1 as a primer number, a convention that is no longer followed. Later on, Euler re-expressed the conjecture as:

Every even number greater than or equal to 4 can be expressed as the sum of two prime numbers.


For example:

  • 8 = 3 + 5. Both 3 and 5 are odd prime numbers.
  • 20 = 3 + 17 = 7 + 13.
  • 42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)


Anyway, your task is now to verify Goldbach's conjecture as expressed by Euler for all even numbers less than a million.

Input 

The input file will contain one or more test cases.

Each test case consists of one even integer n with .

Input will be terminated by a value of 0 for n.

Output 

For each test case, print one line of the form  n  =  a  +  b , where  a  and  b  are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to  n , choose the pair where the difference  b  -  a  is maximized.

If there is no such pair, print a line saying ``Goldbach's conjecture is wrong."

Sample Input 

8
20
42
0

Sample Output 

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

水题。


完整代码:

/*0.049s*/

#include<cstdio>
#include<cmath>
const int maxn = 1000010;
const int m = (int)sqrt(maxn);

bool vis[maxn];

inline void cal_prime()
{
	int i, j;
	for (i = 2; i <= m; ++i)
		if (!vis[i])
			for (j = i * i; j < maxn; j += i)
				vis[j] = true;
}

int main()
{
	cal_prime();
	int n, i;
	while (scanf("%d", &n), n)
	{
		for (i = 3; i < n; ++i)
		{
			if (!vis[i] && !vis[n - i])
			{
				printf("%d = %d + %d\n", n, i, n - i);
				break;
			}
		}
	}
	return 0;
}


你可能感兴趣的:(C++,ACM,uva)