POJ 2115 C Looooops(扩展欧几里得)

C Looooops
http://poj.org/problem?id=2115

Time Limit:  1000MS
Memory Limit: 65536K

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

思路:
你想想,变量前面的系数只可能是C和2^k,常数项为B-A。
故有
Cx+(2^k)y=B-A
求最小正x即可。

完整代码:
/*0ms,164KB*/

#include<cstdio>
using namespace std;

__int64 EXTENDED_EUCLID(__int64 a, __int64 b, __int64& x, __int64& y)
{
	if (b == 0)
	{
		x = 1;
		y = 0;
		return a;
	}
	__int64 d = EXTENDED_EUCLID(b, a % b, x, y);
	__int64 t = x;
	x = y;
	y = t - a / b * y;
	return d;
}

int main(void)
{
	__int64 A, B, C, k;
	while (scanf("%I64d%I64d%I64d%I64d", &A, &B, &C, &k), k)
	{
		__int64 a = C;
		__int64 b = B - A;
		__int64 n = (__int64)1 << k;
		__int64 x, y;
		__int64 d = EXTENDED_EUCLID(a, n, x, y);
		if (b % d)
			printf("FOREVER\n");
		else
		{
			x *= b / d;
			n /= d;
			x = (x % n + n) % n;
			printf("%I64d\n", x);
		}
	}
	return 0;
}

你可能感兴趣的:(POJ 2115 C Looooops(扩展欧几里得))