杭电1250

        一道简单的大数相加题了,用大数模板很容易做的,,题目:

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 


 

Input
Each line will contain an integers. Process to end of file.
 


 

Output
For each case, output the result in a line.
 


 

Sample Input
   
   
   
   
100
 


 

Sample Output
   
   
   
   
4203968145672990846840663646

 

ac代码:

#include <iostream>
#include <string>
using namespace std;
string add(string a,string b)
{
  string max,min;
  max=a;min=b;
  if(a.length()<b.length())
  {
    max=b;min=a;
  }
  int lmax,lmin,l;
  lmax=max.size();
  lmin=min.size();
  l=lmax-1;
  for(int i=lmin-1;i>=0;--i)
  {
    max[l--]+=min[i]-'0';
  }
  for(int j=lmax-1;j>=1;j--)
  {
    if(max[j]>'9')
	{
	  max[j]-=10;
	  max[j-1]++;
	}
  }
  if(max[0]>'9')
  {
    max[0]-=10;
	max='1'+max;
  }
  return max;
}
int main()
{
   
     string f[5008];
	 f[1]="1";f[2]="1";f[3]="1";f[4]="1";
	 for(int i=5;i<5008;++i)
	 {
	   f[i]=add(add(add(f[i-1],f[i-2]),f[i-3]),f[i-4]);
	 }
	 int n;
	 while(cin>>n)
		 cout<<f[n]<<endl;
	 return 0;
}


 

你可能感兴趣的:(String,input,each,output,stdstring)