HDOJ 继续畅通工程 1879(最小生成树)

继续畅通工程

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16515    Accepted Submission(s): 7095


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。
 

Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input
   
   
   
   
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

Sample Output
   
   
   
   
3 1 0
 

Author
ZJU
 

Source
浙大计算机研究生复试上机考试-2008年
 

Recommend
We have carefully selected several similar problems for you:   1875  1102  1856  1301  1325

#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#define INF 0x3f3f3f3f
using namespace std;
int N;
int d[110];
bool used[110];
int cost[101][101];
int prim(){
    for(int i=1;i<=N;i++){
        used[i]=false;
        d[i]=INF;
    }
    d[1]=0;
    int res=0;
    while(1){
        int v=-1;
        for(int i=1;i<=N;i++)
        if(!used[i]&&(v==-1||d[v]>d[i]))v=i;
        if(v==-1)break;
        used[v]=true;
        res+=d[v];
        for(int i=1;i<=N;i++)
        d[i]=min(d[i],cost[v][i]);
    }
    return res;
}
int main()
{
    while(scanf("%d",&N),N){
        int a,b,c,d;
        memset(cost,INF,sizeof(cost));
        for(int i=0;i<N*(N-1)/2;i++){
            scanf("%d%d%d%d",&a,&b,&c,&d);
            if(!d)cost[a][b]=cost[b][a]=c;
            else cost[a][b]=cost[b][a]=0;//建过的话考虑为0。
        }
        printf("%d\n",prim());
    }
    return 0;
}


你可能感兴趣的:(HDOJ 继续畅通工程 1879(最小生成树))