POJ 2459 Feed Accounting(我的水题之路——英文题啊!!!)

Feed Accounting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1368   Accepted: 755

Description

Farmer John is trying to figure out when his last shipment of feed arrived. Starting with an empty grain bin, he ordered and received F1 (1 <= F1 <= 1,000,000) kilograms of feed. Regrettably, he is not certain exactly when the feed arrived. Of the F1 kilograms, F2 (1 <= F2 <= F1) kilograms of feed remain on day D (1 <= D <= 2,000). He must determine the most recent day that his shipment could have arrived. 

Each of his C (1 <= C <= 100) cows eats exactly 1 kilogram of feed each day. For various reasons, cows arrive on a certain day and depart on another, so two days might have very different feed consumption. The input data tells which days each cow was present. Every cow ate feed from Farmer John's bin on the day she arrived and also on the day she left. 

Given that today is day D, determine the minimum number of days that must have passed since his last shipment. The cows have already eaten today, and the shipment arrived before the cows had eaten.

Input

* Line 1: Four space-separated integers: C, F1, F2, and D 

* Lines 2..C+1: Line i+1 contains two space-separated integers describing the presence of a cow. The first integer tells the first day the cow was on the farm; the second tells the final day of the cow's presence. Each day is in the range 1..2,000.

Output

The last day that the shipment might have arrived, an integer that will always be positive.

Sample Input

3 14 4 10
1 9
5 8
8 12

Sample Output

6

Hint

INPUT DETAILS: 

The shipment was 14 kilograms of feed, and Farmer John has 4 kilograms left. He had three cows that ate feed for some amount of time in the last 10 days. 

OUTPUT DETAILS: 

If Farmer John started with 14 kg of feed on day 6, then on days 6 and 7, two kilograms would be eaten each day. On day 8, three kilograms would be eaten. On day 9, two kilograms would be eaten. On day 10, one kilogram would be eaten. Thus, the total eaten would be 2 + 2 + 3 + 2 + 1 = 10, leaving him with 4 kilograms.

Source

USACO 2005 February Silver

好吧,这道是英文题,太难看了,沉住气,沉住气T_T!!

题意理解:就是说有一个人,有F1公斤的草料,需要储存到一个空仓库中,但是不知道要从什么时候开始添加才能够保证,在第D天的时候还剩下F2公斤草料,因为这个人家附近后C头牛出没,他们会来偷吃草料,每头牛来偷吃草料的时间段不一样。如果牛过来吃草料的时候,草料就会少,且每头牛每天吃且仅吃1公斤/天/头。问,如果要保证第D天的时候会剩余下F2公斤草料,需要在哪一天的时候添加这F1公斤草料。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

int account[2100];

int main(void){
    int c, f1, f2, d;
    int day1, day2;
    int i, j, result, tmp;

    while (scanf("%d%d%d%d", &c, &f1, &f2, &d) != EOF){
        memset(account, 0, sizeof(account));
        for (i = 0; i < c; i++){
            scanf("%d%d", &day1, &day2);
            for (j = day1; j <= day2; j++){
                account[j]++;
            }
        }
        tmp = f1 - f2;
        for (i = d; i >= 1 && tmp > 0; i--){
            tmp -= account[i];
        }
        printf("%d\n", i + 1);
    }
    return 0;
}


你可能感兴趣的:(c,Integer,input,each,output)