/*http://acm.hdu.edu.cn/showproblem.php?pid=1159
Common Subsequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17607 Accepted Submission(s): 7391
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
Source
Southeastern Europe 2003
Recommend
Ignatius
解析:
思路及题意:
求最长公共序列长度:
dp[i][j]表示 s1前i个字符和s2前j个字符含有最长的公共序列长度
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[1-i][1-j]+_1;
else
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
Accepted
4216 KB
78 ms
C++
580 B
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include <iostream>
using namespace std;
const int maxn=1000+10;
int dp[maxn][maxn];
char s1[maxn],s2[maxn];
int max(int a,int b)
{
return a>b? a:b;
}
int main()
{ int i,j;
while(scanf("%s",s1)!=EOF)
{
scanf("%s",s2);
memset(dp,0,sizeof(dp));
int n=strlen(s1);
int m=strlen(s2);
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
{
if(s1[i-1]==s2[j-1])
dp[i][j]=dp[i-1][j-1]+1;
else if(dp[i-1][j]>dp[i][j-1])
dp[i][j]=dp[i-1][j];
else
dp[i][j]=dp[i][j-1];
}
printf("%d\n",dp[n][m]);
}
return 0;
}