poj2352 Stars

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 38791   Accepted: 16880

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
poj2352 Stars_第1张图片
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999



树状数组裸题

注意坐标是从0开始的,所以在处理时要将所有坐标加1,因为树状数组只可以处理大于1的数




#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#define F(i,j,n) for(int i=j;i<=n;i++)
#define D(i,j,n) for(int i=j;i>=n;i--)
#define MAXN 32005
#define LL long long
#define pa pair<int,int>
using namespace std;
int n,x,y,a[MAXN],ans[15005];
int read()
{
	int ret=0,flag=1;char ch=getchar();
	while (ch<'0'||ch>'9'){if (ch=='-') flag=-1;ch=getchar();}
	while (ch>='0'&&ch<='9'){ret=ret*10+ch-'0';ch=getchar();}
	return ret*flag;
}
void add(int k)
{
	for(int i=k;i<MAXN;i+=i&(-i)) a[i]++;
}
int getsum(int k)
{
	int ret=0;
	for(int i=k;i>0;i-=i&(-i)) ret+=a[i];
	return ret;
}
int main()
{
	memset(a,0,sizeof(a));
	memset(ans,0,sizeof(ans));
	n=read();
	F(i,1,n)
	{
		x=read();y=read();
		x++;y++;
		ans[getsum(x)]++;
		add(x);
	}
	F(i,0,n-1) printf("%d\n",ans[i]);
}


你可能感兴趣的:(poj)