Common Subsequence
http://poj.org/problem?id=1458
Time Limit:
1000MS
Memory Limit: 10000K
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x
ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
4
2
0
参考这篇文章。
完整代码:
/*POJ: 0ms,964KB*/
/*HDU: 31ms,2176KB*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1010;
char a[maxn], b[maxn];
int dp[maxn][maxn];
int main(void)
{
while (~scanf("%s%s", a, b))
{
int lena = strlen(a), lenb = strlen(b);
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= lena; ++i)
for (int j = 1; j <= lenb; ++j)
dp[i][j] = (a[i - 1] == b[j - 1] ? dp[i - 1][j - 1] + 1 : max(dp[i - 1][j], dp[i][j - 1]));
printf("%d\n", dp[lena][lenb]);
}
return 0;
}