POJ 3438 Look and Say(我的水题之路——N个M的队列)

Look and Say
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 7678   Accepted: 4638

Description

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.

Input

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.

Output

For each test case, print the string that follows the given string.

Sample Input

3
122344111
1111111111
12345

Sample Output

1122132431
101
1112131415

Source

Rocky Mountain 2007

和1016题意一样,而且更简单。
题目要求将数n按一定规则进行转换,比如:1231560,这个数字中有1个0、2个1、1个2、1个3、1个5、1个6,则,其转换后的下一个数字为102112131516。

直接读取当前数字id,并同时计算个数num,当读取的数字和id不相同,则输出id和num,再将当前数字保存到id,知道字符串读取完成。

注意点:
1)末尾的id和num,可能忘记输出,造成错误。

代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>

char str[1100];

int main(void){
    int ii, casenum;
    int len, num, id;
    int i, j;
    char last;

    scanf("%d", &casenum);
    getchar();
    for (ii = 0; ii < casenum; ii++){
        scanf("%s", str);
        len = strlen(str);
        for (i = 1, id = (str[0] - '0'), num = 1; i < len ; i++){
            if (str[i] - '0' == id){
                num++;
            }
            else{
                printf("%d%d", num, id);
                id = str[i] - '0';
                num = 1;
            }
        }
        printf("%d%d", num, id);
        printf("\n");
    }
    return 0;
}


你可能感兴趣的:(String,input,UP,each,output)