POJ 1797 dijkstra()变形

      话说这道题本来上午就应该ac的,结果网速太慢,,一直没提交上,,悲剧的是中午吃饭回来后竟然停电了,一直到下午5点才来电,提交竟然wa,,,然后就是找错误,,找了好久,竟然是写dijkstra有一个地方写错了,,,悲剧啊,,弱爆了。。。。。。题目:

Heavy Transportation
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 13935   Accepted: 3673

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4
ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
#define MAX 0x7fffffff
#define MIN -0x7fffffff
const int N=1010;
int numcity,numpath;
int map[N][N],visted[N];
__int64 dis[N];
int max(int a,int b){
  return a>b?a:b;
}
int min(int a,int b){
  return a<b?a:b;
}
void dijkstra(){
  memset(visted,0,sizeof(visted));
  visted[1]=1;
  for(int i=2;i<=numcity;++i)
	  dis[i]=MIN;
  dis[1]=MAX;
  int pos=1;
  for(int i=1;i<=numcity;++i){
	  for(int j=1;j<=numcity;++j){
		if(map[pos][j]!=MAX)
	       dis[j]=max(dis[j],min(dis[pos],map[pos][j]));
	  }
	  int mmin=0;
	  for(int i=1;i<=numcity;++i){
		  if(!visted[i]&&mmin<dis[i]){
		    mmin=dis[i];
			pos=i;
		  }
	  }
	  visted[pos]=1;
  }
}
int main(){
  //freopen("1.txt","r",stdin);
  int numcase;
  scanf("%d",&numcase);
  for(int k=1;k<=numcase;++k){
    scanf("%d%d",&numcity,&numpath);
	int x,y,z;
	for(int i=1;i<=numcity;++i){
	  for(int j=1;j<=numcity;++j)
		  map[i][j]=map[j][i]=MAX;
	}
	while(numpath--){
	  scanf("%d%d%d",&x,&y,&z);
	  map[y][x]=map[x][y]=z;
	}
	dijkstra();
	//printf("\n");
	printf("Scenario #%d:\n",k);
	printf("%I64d\n\n",dis[numcity]);
  }
  return 0;
}


你可能感兴趣的:(POJ 1797 dijkstra()变形)