[贪心]UVA10602 Editor Nottoobad

Problem C

EDITOR NOTTOOBAD

 

Company Macrohard has released it’s new version of editor Nottoobad, which can understand a few voice commands. Unfortunately, there are only two voice commands that it can understand – “repeat the last word”, “delete the last symbol”. However, when one uses “repeat the last word” the editor inserts a blank that separates the words. But the company claims that it is possible to type much faster – simply by less number of presses. For example, such a phrase like “this thin thing” requires only 6 presses of the keyboard.

 

Action

Number

of presses

Content of the document

Press "this"

4

This

Say “repeat the last word”

0

this this

Say “delete the last symbol”

0

this thi

Press "n"

1

this thin

Say “repeat the last word”

0

this thin thin

Press "g"

1

this thin thing

 

In order to increase the popularity of it’s product the company decided to organize a contest where the winner will be a person who types a given number of words with minimum number of presses. Moreover, the first word must be typed first, and all the others can be typed in arbitrary order. So, if words “apple”, “plum” and “apricote” must be typed, the word “apple” must be typed first, and the words “plum” and “apricote” can be switched. And the most important for you – you are going to take part in the contest and you have a good friend in the company, who told you the word which will be used in the contest. You want be a winner J, so you have to write a program which finds the order of the words, where the number of presses will be minimum.

 

Input

The first line of the input contains the T (1≤T≤15) the number of test cases. Then T test cases follow. The first line of each test contains a number N (1≤N≤100) – the number of words that must be pressed. Next N lines contain words – sequences of small Latin letters, not longer than 100 symbols. Remember that the first word must be pressed first!

 

Output

The first line of the output contains number X - the minimum number of presses, which one has to do in order to type all the words using editor Nottoobad. Next N lines contain the words in that minimum order. If there are several solutions, you can output one of them.

 

 

 

 

 

Sample Input

Sample Output

3

3

this

thin

thing

4

popcorn

apple

apricote

plum

2

hello

hello

6

this

thin

thing

21

popcorn

plum

apricote

apple

5

hello

hello

 

Problem source: Russian National Team Olympiad 2000

Problem author: Andrew Stankevich

Problem translation: Dmytro Chernysh

Problem solution: Andrew Stankevich, Dmytro Chernysh

 


题意:一种编辑器只能通过声音做到两种操作-“repeat the last word”, “delete the last symbol”,其他的都必须自己手动输入,问输入一些单词,最少需要手写输入多少次。

思路:这是比较典型得贪心法了,要使得手写输入最少,首先要寻找出最大的匹配前缀,因此把所有的单词按照字典序排序,得到得序列是最优,因为前缀有匹配得都会排到相邻位置。

代码:

 #include<iostream>
#include<algorithm>
#include<string>

using namespace std;

string st[200];

bool cmp(string str1,string str2)
{
  return str1<str2;
}

int suffix(string str1,string str2)
{
  int len=min(str1.size(),str2.size());
  int i;
  for(i=0;i<len;i++)
    {
      if(str1[i]!=str2[i]) break;
    }
  return i;
}

int main()
{
  int n,m;
  cin>>n;
  
  while(n--)
    {
      cin>>m;
      int i,j,k;
      string str;
      for(i=0;i<m;i++)
	{
	  cin>>st[i];
	}
      sort(st,st+m,cmp);
      int len=st[0].size();
      for(i=1;i<m;i++)
	{
	  len=len+st[i].size()-suffix(st[i-1],st[i]);
	}
      cout<<len<<endl;
      for(i=0;i<m;i++)
	cout<<st[i]<<endl;
    }
}


你可能感兴趣的:(贪心)