A Knight's Journey
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 25493 |
|
Accepted: 8686 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1
Scenario #2:
impossible
Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
这是一道深搜的题目,主要是要回溯,这个题还有就是要按字典序来输出,所以方向数组就不能像以前那样写了,要按8个方向的字典序搜索,我表示我被坑的是格式居然错了,老是pe,最后才发现少了一个:,以后一定要注意细节。
下面是代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <vector>
#include <cassert>
#include <cstdlib>
using namespace std;
const int maxn=1000;
int map[maxn][maxn];
int sx[maxn],sy[maxn];
int dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};//这点一定要注意,我写的时候不仔细老是wa
int p,q,flag,step;
void init(){
for(int i=1;i<=p;i++)
for(int j=1;j<=q;j++)
map[i][j]=0;
}
void dfs(int i,int j){
if(flag)
return;
int x,y,k;
step++;
sx[step]=i;
sy[step]=j;
if(step==p*q)
{
flag=1;
return;
}
map[i][j]=1;
for(int k=0;k<8;k++){
y=j+dir[k][0];
x=i+dir[k][1];
if(map[x][y]==0&&x>0&&x<=p&&y>0&&y<=q){
dfs(x,y);
step--;
}
}
map[i][j]=0;
}
int main(){
int n,count=0;
cin>>n;
while(n--){
step=0;
flag=0;
count++;
cin>>p>>q;
init();
dfs(1,1);
cout<<"Scenario #"<<count<<":"<<endl;
if(flag){
for(int i=1;i<=p*q;i++)
printf("%c%d",sy[i]+64,sx[i]);//表示这一点输出是从网上的大牛那里学到的
printf("\n");
}
else
cout<<"impossible"<<endl;
if(n!=0) cout<<endl;//这点要注意最后一行是没空行的,不然会pe
}
return 0;
}