hdu-1902 The Dragon of Loowater

Problem Description
Once upon a time, in the Kingdom of Loowater, a minor nuisance turned into a major problem.
The shores of Rellau Creek in central Loowater had always been a prime breeding ground for geese. Due to the lack of predators, the geese population was out of control. The people of Loowater mostly kept clear of the geese. Occasionally, a goose would attack one of the people, and perhaps bite off a finger or two, but in general, the people tolerated the geese as a minor nuisance.

One day, a freak mutation occurred, and one of the geese spawned a multi-headed fire-breathing dragon. When the dragon grew up, he threatened to burn the Kingdom of Loowater to a crisp. Loowater had a major problem. The king was alarmed, and called on his knights to slay the dragon and save the kingdom.

The knights explained: "To slay the dragon, we must chop off all its heads. Each knight can chop off one of the dragon's heads. The heads of the dragon are of different sizes. In order to chop off a head, a knight must be at least as tall as the diameter of the head. The knights' union demands that for chopping off a head, a knight must be paid a wage equal to one gold coin for each centimetre of the knight's height."

Would there be enough knights to defeat the dragon? The king called on his advisors to help him decide how many and which knights to hire. After having lost a lot of money building Mir Park, the king wanted to minimize the expense of slaying the dragon. As one of the advisors, your job was to help the king. You took it very seriously: if you failed, you and the whole kingdom would be burnt to a crisp!
 

Input
The input contains several test cases. The first line of each test case contains two integers between 1 and 20000 inclusive, indicating the number n of heads that the dragon has, and the number m of knights in the kingdom. The next n lines each contain an integer, and give the diameters of the dragon's heads, in centimetres. The following m lines each contain an integer, and specify the heights of the knights of Loowater, also in centimetres.
The last test case is followed by a line containing:
0 0
 

Output
For each test case, output a line containing the minimum number of gold coins that the king needs to pay to slay the dragon. If it is not possible for the knights of Loowater to slay the dragon, output the line:
Loowater is doomed!
 

Sample Input
   
   
   
   
2 3 5 4 7 8 4 2 1 5 5 10 0 0
 

Sample Output
   
   
   
   
11 Loowater is doomed!
水题~~
但我还是花了点时间。。。大体意思就是:
给出两个数,分别代表龙的头的个数和骑兵的人数,接下来先给出各个龙的头的高度,然后是骑兵的高度,一个骑兵只能杀死一个龙头,当且仅当骑兵的高度大于后等于龙的头的高度时,骑兵可以杀死龙头。骑兵的高度1个单位代表1个金币,求要杀死所有的龙头的所需要的最少的金币。如果没有满足要求的,输出Loowater is doomed!。。
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dragon[20010];
int knight[20010];
int cmp(int a,int b){
	return a<b;
}
int main(){
	int n,m;
	int i,j,k,t,ans;
	while(~scanf("%d%d",&n,&m),n+m!=0){
		memset(dragon,0,sizeof(dragon));
		memset(knight,0,sizeof(knight));
		for(i=0;i<n;i++)
		   scanf("%d",&dragon[i]);
		sort(dragon,dragon+n,cmp);
		for(i=0;i<m;i++)
		   scanf("%d",&knight[i]);
		   sort(knight,knight+m,cmp);
		   ans=0;
		  // j=0;
		   i=0;
	      for(j=0;j<m;j++){//从骑兵开始进行,如果骑兵能杀死龙的话,i++ 
	      	if(dragon[i]<=knight[j]&&i<n){     //对i进行限制 
	      		ans+=knight[j];
	      		i++;
	      	}
	      }
	     // printf("%d\n",i);
	      if(i==n)
	        printf("%d\n",ans);
	      else 
	        printf("Loowater is doomed!\n");
	}
	return 0;
} 


你可能感兴趣的:(hdu-1902 The Dragon of Loowater)