新手入门--输出格式八

新手入门

输出格式八:

A+B for Input-Output Practice (VIII)

Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
   
   
   
   
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 
Sample Output
   
   
   
   
10 15 6

注:两行之间输出一个空行,最后一行没有空行!

代码:

#include<stdio.h>
int main()
{
    int n,m,i,j,sum,a;
    scanf("%d",&n);
    for(i=0;i<n;i++){
        sum=0;
        scanf("%d",&m);
        for(j=0;j<m;j++){
            scanf("%d",&a);
            sum+=a;
        }
        printf("%d\n",sum);
        if(i!=n-1)
            printf("\n");
    }
    return 0;
}

 

你可能感兴趣的:(新手入门--输出格式八)