1002. A+B for Polynomials (25)

题目:

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
注意:
1、创建一个长度为1001的数组,类似于hash表的思想,数组中的每一个元素保存相应级次的系数。
2、输出时根据系数的大小是否为0判断是否输出。

代码:
#include <iostream>
#include <stdio.h>
#include <string>
using namespace std;
int main()
{
	int k1, k2, k3;
	int num;
	double temp;
	double N1[1001];
	int i;
	cin >> k1;
	for(i = 0; i < 1001; ++ i)
		N1[i] = 0;
	for(i = 0; i < k1; ++ i)
	{
		cin >> num;
		cin >> N1[num];
	}
	cin >> k2;
	for(i = 0; i < k2; ++ i)
	{
		cin >> num >> temp;
		N1[num] += temp;
	}
	k3 = 0;
	for(i = 0; i < 1001; ++ i)
	{
		if(N1[i] != 0)
			++ k3;
	}
	cout <<k3;
	for(i = 1000; i >=0; -- i)
	{
		if(N1[i] != 0)
			printf(" %d %.1lf", i, N1[i]);
	}
	return 0;
}











你可能感兴趣的:(1002. A+B for Polynomials (25))