1063. Set Similarity (25)

题目:

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%
注意:
1、直接使用set容器,把重复的剔除掉。
2、然后merge归并,计出重复的个数和总个数。

代码:
#include<iostream>
#include<vector>
#include<set>
using namespace std;

int main()
{
	vector<set<int>>allset;
	int n;
	scanf("%d",&n);
	allset.resize(n);
	int max;
	for(int i=0;i<n;++i)
	{
		int k;
		scanf("%d",&k);
		for(int j=0;j<k;++j)
		{
			int t;
			scanf("%d",&t);
			allset[i].insert(t);
		}
	}
	int m;
	scanf("%d",&m);
	for(int i=0;i<m;++i)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		--a; --b;//the i-th set is in set[i-1]
		float nt=0,nc=0;
		set<int>::iterator a_iter,b_iter;
		a_iter=allset[a].begin();
		b_iter=allset[b].begin();
		int cur=-1;
		for(int j=0;j<allset[a].size()+allset[b].size();++j)
		{//merge
			int next;
			if(a_iter!=allset[a].end() && b_iter!=allset[b].end())
			{
				if(*a_iter<*b_iter)
					next=*a_iter++;
				else
					next=*b_iter++;
			}
			else if(a_iter==allset[a].end())
				next=*b_iter++;
			else if(b_iter==allset[b].end())
				next=*a_iter++;
			if(next!=cur)
				++nt;
			else
				++nc;
			cur=next;
		}
		printf("%.1f%%\n",100*nc/nt);
	}
	return 0;
}

你可能感兴趣的:(考试,pat,浙江大学)