HDU 5477 A Sweet Journey

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 703    Accepted Submission(s): 363


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)

HDU 5477 A Sweet Journey_第1张图片
 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri , which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means Ri<Li+1 for each i ( 1i<n ).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
   
   
   
   
1 2 2 2 5 1 2 3 4
 

Sample Output
   
   
   
   
Case #1: 0
 

Source
2015 ACM/ICPC Asia Regional Shanghai Online 

题意:一个人骑自行车旅行,路的长度为L,陆地上每里获得b点力量,沼泽中每里失去a点力量,n为沼泽的数量,下面的nz组数据代表沼泽的起点和终点。
沼泽的顺序都是从起点到终点的,不用考虑顺序。简单模拟接可以了。


AC代码:
#include <cstdio>
#include <algorithm>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
int main()
{
    int t,a,b,l,n;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&n,&a,&b,&l);
        int sum=0;
        int last=0;
        int maxn=INF;
        while(n--)
        {
            int start,end;
            scanf("%d%d",&start,&end);
            sum+=(b*(start-last)-a*(end-start));
            maxn=min(maxn,sum);
            last=end;
        }
        printf("Case #%d: ",++kase);
        if(maxn<0)
            printf("%d\n",-maxn);
        else
            printf("0\n");
    }
    return 0;
}


你可能感兴趣的:(a,Journey,Sweet,HDU547)