hdu 5375 Gray code 2015多校联合训练赛#7

Gray code

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 369    Accepted Submission(s): 205


Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.



Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
 

Input
The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)
 

Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
 

Sample Input
   
   
   
   
2 00?0 1 2 4 8 ???? 1 2 4 8
 

Sample Output
   
   
   
   
Case #1: 12 Case #2: 15
Hint
https://en.wikipedia.org/wiki/Gray_code http://baike.baidu.com/view/358724.htm
 

Source
2015 Multi-University Training Contest 7




#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 200007
char w[maxn];
int num[maxn];
long long dp[maxn][2];


int main(){
    int t,tt=1;
    scanf("%d",&t);
    while(t--){
        scanf("%s",w);
        int n = strlen(w);
        for(int i = 0;i < n; i++)
            scanf("%d",num+i);
        long long inf = -1000000000000ll;
        if(w[0] == '?'){
            dp[0][1] = num[0];
            dp[0][0] = 0;
        }
        else if(w[0] == '0'){
            dp[0][0] = 0;
            dp[0][1] = inf;
        }
        else {
            dp[0][0] = inf;
            dp[0][1] = num[0];
        }


        for(int i = 1;i < n; i++){
            if(w[i] == '0'){
                dp[i][0] = max(dp[i-1][1] + num[i],dp[i-1][0]);
                dp[i][1] = inf;
            }
            else if(w[i] == '1'){
                dp[i][0] = inf;
                dp[i][1] = max(dp[i-1][0] + num[i],dp[i-1][1]);
            }
            else {
                dp[i][0] = max(dp[i-1][1] + num[i],dp[i-1][0]);
                dp[i][1] = max(dp[i-1][0] + num[i],dp[i-1][1]);
            }
        }
        printf("Case #%d: %I64d\n",tt++,max(dp[n-1][0],dp[n-1][1]));
    }
    return 0;
}



你可能感兴趣的:(HDU,2015多校联合训练赛,5375)