Stupid Tower Defense
Time Limit: 12000/6000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 885 Accepted Submission(s): 264
Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.
The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.
The red tower damage on the enemy x points per second when he passes through the tower.
The green tower damage on the enemy y points per second after he passes through the tower.
The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)
Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.
FSF now wants to know the maximum damage the enemy can get.
Input
There are multiply test cases.
The first line contains an integer T (T<=100), indicates the number of cases.
Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)
Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.
Sample Input
Sample Output
Case #1: 12
Hint
For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.
题意:三种塔,红色在当前格子受到每单位时间x伤害,绿色在下一个位置每个单位时间受到y伤害,
蓝色在下一个位置每次停留时间增加z
可知红色一定是放在最后的,而且是连续放置,
dp[i][j]表示i个位置放置了j个绿色的塔,造成的最大伤害,
转移为dp[i][j] --->dp[i+1][j],dp[i+1][j+1]表示当前位置放置蓝色或者绿色塔,在下一时刻,造成的最大伤害
因为蓝色和绿色塔都是在下一个时刻起作用的。
然后枚举从第几个位置开始放红色的塔
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define max(x,y) x>y?x:y
#define maxn 1507
#define ll long long
ll dp[maxn][maxn];
ll n,dg,db,dr,st;
void init(int tt){
ll t1,t2,ans=0;
memset(dp,0,sizeof(dp));
for(int i = 1;i < n; i++){
for(int j = 0;j < i;j++){
t1 = st+db*(i-j-1);
t2 = st+db*(i-j);
dp[i+1][j] = max(dp[i+1][j],dp[i][j]+j*dg*t2);
dp[i+1][j+1] = dp[i][j]+(j+1)*dg*t1;
}
}
for(int i = 1;i <= n; i++){
for(int j = 0;j < i;j++){
t1 = (i-j-1)*db+st;
t2 = t1*(n-i+1);
ans = max(ans,dp[i][j]+dr*t2+dg*(t2-t1)*j);
}
}
printf("Case #%d: %I64d\n",tt,ans);
}
int main(){
int t;
scanf("%d",&t);
for(int tt = 1; tt <= t; tt++){
scanf("%I64d%I64d%I64d%I64d%I64d",&n,&dr,&dg,&db,&st);
init(tt);
}
return 0;
}