最短路径__Wormholes( Poj )

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between S and E that requires Tseconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. MW+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意:虫洞问题,现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b话费的时间是-c(时间倒流,并且虫洞是单向的),现在问你能否从某个点走可以回到从前.


思路: 检测是否有负权环.


#include <stdio.h>
#include <string.h>
#define N 510
#define M 5300
#define INF 999999999
struct edge
{
    int u,v,s;
}edge[M];
int m,n,w;
int dis[N];

bool Bellman_ford(int len)
{
    int i,j,k;
    bool sure;
    for(i = 0 ; i < n-1 ; i ++)
    {
        sure = true;
        for(j = 0 ; j < len ; j ++)
        {
            if(dis[edge[j].u] > dis[edge[j].v] + edge[j].s)
                dis[edge[j].u] = dis[edge[j].v] + edge[j].s,sure = false;
        }
        if(sure)break;
    }
    for(j = 0 ; j < len ; j ++)
    {
        if(dis[edge[j].u] > dis[edge[j].v] + edge[j].s) return true;
    }
    return false;
}

int main()
{
    int t,i,j,u,v,s,len;
    scanf("%d",&t);
    while(t--)
    {
        len = 0;
        scanf("%d %d %d",&n,&m,&w);
        for(i = 0 ; i < m ; i ++)
        {
            scanf("%d %d %d",&u,&v,&s);
            edge[len].u = edge[len+1].v = u;
            edge[len].v = edge[len+1].u = v;
            edge[len++].s = s;
            edge[len++].s = s;
        }
        for(i = 0 ; i < w; i ++)
        {
            scanf("%d %d %d",&u,&v,&s);
            edge[len].u = u;
            edge[len].v = v;
            edge[len++].s = -s;
        }
        for(i = 1 ; i <= n ; i ++) dis[i] = INF;
        if(Bellman_ford(len))
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}




你可能感兴趣的:(最短路径,bellman_ford)