HDU-1096-A+B for Input-Output Practice (VIII)(最后一行不输出空格)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 114146    Accepted Submission(s): 35013


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
   
   
   
   
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 

Sample Output
   
   
   
   
10 15 6
 

Author
lcy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1061  1108  1229  1003  2074 


#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int n,k,a,sum;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d",&k);
        for(int i=0;i<k;i++)
        {
            scanf("%d",&a);
            sum+=a;
        }
        if(n!=0)
            printf("%d\n\n",sum);
        else
            printf("%d\n",sum);
    }
}



 

你可能感兴趣的:(今天就水到这里,水题结束,最后一行无空行)