HDU-2317-Nasty Hacks

Nasty Hacks

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2565    Accepted Submission(s): 2012


Problem Description
You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

 

Input
The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -10 6 ≤ r, e ≤ 10 6 and 0 ≤ c ≤ 10 6.
 

Output
Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.
 

Sample Input
   
   
   
   
3 0 100 70 100 130 30 -100 -70 40
 

Sample Output
   
   
   
   
advertise does not matter do not advertise
 

Source
Nordic 2006
 

Recommend
zty   |   We have carefully selected several similar problems for you:   2320  2322  2321  2323  2315 


这题绝逼农夫山泉,不解释!


import java.io.*;
import java.util.*;

public class Main
{

	public static void main(String[] args)
	{
		int n, a, b, c;
		Scanner input = new Scanner(System.in);
		n = input.nextInt();
		for (int i = 0; i < n; i++)
		{
			a = input.nextInt();
			b = input.nextInt();
			c = input.nextInt();
			if (b - c > a)
			{
				System.out.println("advertise");
			} else if (b - c == a)
			{
				System.out.println("does not matter");
			} else
			{
				System.out.println("do not advertise");
			}
		}
	}

}




你可能感兴趣的:(java,数据结构,编程,ACM,HDU)