HDU-1097-A hard puzzle( 快速幂取模 )

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37387    Accepted Submission(s): 13380


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
   
   
   
   
7 66 8 800
 

Sample Output
   
   
   
   
9 6
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1061  1170  1106  1159  1108 
 


考的是快速幂取模算法,就不找规律了,感觉找规律也挺难的.....(快速幂取模参考上一篇文章)


#include<iostream>
#include<cstdio>
using namespace std;
int modexp_recursion(int a,int b,int n)       
{      
    int t = 1;  
  
    if (b == 0)  
        return 1;  
  
    if (b == 1)  
         return a%n;  
  
    t = modexp_recursion(a, b>>1, n);  
  
    t = t*t % n;  
  
    if (b&0x1)  
    {      
        t = t*a % n;  
    }  
  
    return t;  
 }

int main()
{
  int a,b;
  while(scanf("%d%d",&a,&b)!=EOF)
  {
     cout<<modexp_recursion(a,b,10)<<endl;
  }
  return 0;
}




你可能感兴趣的:(C++,C语言,ACM,HDU)