hdu 2199 Can you solve this equation?

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1226    Accepted Submission(s): 625

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

 

Sample Input
  
2 100 -4

 

Sample Output
  
1.6152 No solution!
          
       简单的二分,我第一道二分题目。
代码:
#include <iostream>
#include <stdio.h>
#include <cmath>
using namespace std;

const double eps = 1e-12;
double x, y;

double calc(double x)
{
    return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
}

int main()
{
    int t;
    double mid, left, right;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lf", &y);
        left = 0; right = 100;
        if(calc(left) > y || calc(right) < y)
        {
            printf("No solution!\n");
            continue;
        }
        while(right - left > eps)   //二分查找
        {
            mid = (right+left)/2.0;
            if(calc(mid) > y) right = mid;
            else left = mid;
        }
        printf("%.4lf\n", mid);
    }

    return 0;
}
 

你可能感兴趣的:(数据结构,C++,c,算法,ACM)