Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7904 Accepted Submission(s): 2949
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
这题就是最简单的01背包,逆序!!!
for i=1..N for v=V..0
f[v]=max{f[v],f[v-c[i]]+w[i]};
链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
using namespace std;
int c[1005], w[1005];
int bag[1005];
int N, V;
void _01_bag() //01背包:逆序!
{
int i, j;
memset(bag, 0, sizeof(bag));
for(i = 0; i < N; i++)
{
for(j = V; j >= c[i]; j--)
{
bag[j] = max(bag[j], bag[j-c[i]] + w[i]);
}
}
}
int main()
{
int i, t;
scanf("%d", &t);
while(t--)
{
scanf("%d %d", &N, &V);
for(i = 0; i < N; i++)
scanf("%d", &w[i]);
for(i = 0; i < N; i++)
scanf("%d", &c[i]);
_01_bag();
printf("%d\n", bag[V]);
}
return 0;
}