hdu 5443 The Water Problem(RMQ区间最值)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=5443

Problem Description
In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,an representing the size of the water source. Given a set of queries each containing 2 integers l and r , please find out the biggest water source between al and ar .
 

Input
First you are given an integer T(T10) indicating the number of test cases. For each test case, there is a number n(0n1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,...,an , and each integer is in {1,...,106} . On the next line, there is a number q(0q1000) representing the number of queries. After that, there will be q lines with two integers l and r(1lrn) indicating the range of which you should find out the biggest water source.
 

Output
For each query, output an integer representing the size of the biggest water source.
 

Sample Input
   
   
   
   
3 1 100 1 1 1 5 1 2 3 4 5 5 1 2 1 3 2 4 3 4 3 5 3 1 999999 1 4 1 1 1 2 2 3 3 3
 

Sample Output
   
   
   
   
100 2 3 4 4 5 1 999999 999999 1
分析:最开始不知道RMQ算法,用线段树做的,代码写的挺长。现在了解了RMQ区间最值算法,重新写一遍。
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=1e3+10;
int maxsum[maxn][20]; //minsum[maxn],
void RMQ(int sum){
    for(int j=1;j<20;j++){
        for(int i=1;i<=sum;i++){
            if(i+(1<<j)-1<=sum){
                maxsum[i][j]=max(maxsum[i][j-1],maxsum[i+(1<<(j-1))][j-1]);
                //minsum[i][j]=min(maxsum[i][j-1],minsum[i+(1<<(j-1))][j-1]);
            }
        }
    }
}
int main()
{
    //freopen("cin.txt","r",stdin);
    int t,sum,a,q;
    cin>>t;
    while(t--){
        scanf("%d",&sum);
        for(int i=1;i<=sum;i++){
            scanf("%d",&a);
            //minsum[i][0]=
            maxsum[i][0]=a;
        }
        RMQ(sum);
        scanf("%d",&q);
        int l,r;
        while(q--){
            scanf("%d%d",&l,&r);
            int k=(int)log2(r-l+1.0);
            printf("%d\n",max(maxsum[l][k],maxsum[r-(1<<k)+1][k]));
        }
    }
    return 0;
}


你可能感兴趣的:(HDU,区间最值)