UVA 10055 Hashmat the brave warrior

Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.

 

Input

The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.

 

Output

For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

 

Sample Input:

10 12
10 14

100 200

 

Sample Output:

2
4

100

 

 

 

//#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>


using namespace std;


#define MAXN 1000


int main(){


#ifndef ONLINE_JUDGE
	freopen("10055.in", "r", stdin);
	freopen("10055.out", "w", stdout); 
#endif

	// 必须用long类型来通过
	unsigned long int a, b;

	while (scanf("%lu%lu", &a, &b) == 2)
	{
		if(a >= b){
			printf("%lu\n", a-b);
		}
		else{
			printf("%lu\n", b-a);
		}
	}


}


#endif




你可能感兴趣的:(hash)