UVA 10098 - Generating Fast

Generating permutation has always been an important problem in computer science. In this problem you will have to generate the permutation of a given string in ascending order.  Remember that your algorithm must be efficient.


Input

The first line of the input contains an integer n, which indicates how many strings to follow. The next n lines contain n strings. Strings will only contain alpha numerals and never contain any space. The maximum length of the string is 10.

 
Output

For each input string print all the permutations possible in ascending order. Not that the strings should be treated, as case sensitive strings and no permutation should be repeated. A blank line should follow each output set.

 

Sample Input

3
ab
abc
bca

 

 

 

Sample Output

ab
ba

abc
acb
bac
bca
cab
cba

abc
acb
bac
bca
cab
cba

 

 

直接调用库函数next_permutation,在调用前要用qsort先排序下

 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>
#include <ctime>

using namespace std;

#define MAXN 110

char buf[MAXN];

int cmp( const void *a , const void *b )  
{
	return *(char *)a - *(char *)b;  
} 

int main(){

#ifndef ONLINE_JUDGE
	freopen("10098.in", "r", stdin);
	freopen("out.out", "w", stdout);
#endif

	int n;
	scanf("%d", &n);
	while(n--){
		memset(buf, 0, sizeof(buf));
		scanf("%s", buf);
		qsort(buf, strlen(buf), sizeof(buf[0]), cmp);

		do {
			printf("%s\n", buf);
		} while ( next_permutation(buf, buf+strlen(buf)) );
		printf("\n");
	}
}


#endif

 

你可能感兴趣的:(uva)