poj1258解题报告

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15626   Accepted: 6327

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
题目大意:给定一个N村庄和一个N^2的邻接矩阵表示每两个村庄间的距离,求将这N个点联通所需的最小电线长度  。。
思路:典型的最小生成树,我用的prim算法,就是开始随便取一个点,找出这个点和为加入的哪个点距离最短,再将那个点也加入到被选中的
集合中,反复重复这个过程直到将所有点加入到被选中集合。。。47ms水锅
#include<iostream>
using namespace std;
int main()
{
	
	int dis[101][101],lock[101],n,i,j,min,finded,p,s;
	while(cin>>n&&n)
	{
		memset(lock,0,sizeof(lock));
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				cin>>dis[i][j];
		lock[0]=1;
		finded=1;
		s=0;
		while(finded!=n)
		{
			min=100000000;
			for(i=0;i<n;i++)
				for(j=0;j<n;j++)
					if(lock[i]==1&&lock[j]==0)
						if(dis[i][j]<min)
						{	min=dis[i][j];	p=j;	}
			s+=min;	lock[p]=1;	
			finded++;
		}
		cout<<s<<endl;

	}
	return 0;
}

 

你可能感兴趣的:(Integer,input,each,internet,output,distance)