UVA 662 Fast Food(dp)

  Fast Food 

The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurent and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.


To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers  (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number  will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.

Input 

The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers  n  and  k n  and  k  will satisfy  . Following this will  n lines containing one integer each, giving the positions  d i  of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.

Output 

For each chain, first output the number of the chain. Then output an optimal placement of the depots as follows: for each depot output a line containing its position and the range of restaurants it serves. If there is more than one optimal solution, output any of them. After the depot descriptions output a line containing the total distance sum, as defined in the problem text.


Output a blank line after each test case.

Sample Input 

6 3
5
6
12
19
20
27
0 0

Sample Output 

Chain 1
Depot 1 at restaurant 2 serves restaurants 1 to 3
Depot 2 at restaurant 4 serves restaurants 4 to 5
Depot 3 at restaurant 6 serves restaurant 6
Total distance sum = 8

题意:给定n间快餐店坐标,m个仓库,仓库是建在餐厅上的,要求出最小距离和。使得每个餐厅都有一个仓库服务他。

思路:dp,dp[i][j], 表示i间仓库可以提供给j间餐厅的最小距离, 每个仓库服务给周围仓库距离最小的位置为中位数,所以 dp[i][j] = min(dp[i][j], dp[i -1][k] + dis[k + 1][j]); 其中k之后由一个仓库来服务,说白了,就是放一个仓库下去,看放在哪个位置使得最小,有点类似区间dp。

代码:

#include <stdio.h>
#include <string.h>

int n, m, num[205], sum[205], way[205][205];
int dis[205][205];
int dp[205][205];

void print(int i, int j) {
    int t = way[i][j];
    if (i > 1) 
	print(i - 1, t);
    if (t + 1 != j)
	printf("Depot %d at restaurant %d serves restaurants %d to %d\n", i, (t + 1 + j)/ 2, t + 1, j);
    else
	printf("Depot %d at restaurant %d serves restaurant %d\n", i, (t + 1 + j)/ 2, t + 1);
}
int main() {
    int t = 1;
    while (~scanf("%d%d", &n, &m) && n || m) {
	memset(sum, 0, sizeof(sum));
	memset(way, 0, sizeof(way));
	for (int i = 1; i <= m; i ++)
	    for (int j = 1; j <= n; j ++)
		dp[i][j] =  999999999;
	for (int i = 1; i <= n; i ++) {
	    scanf("%d", &num[i]);
	    sum[i] = sum[i - 1] + num[i];
	}
	for (int i = 1; i <= n; i ++) {
	    for (int j = 1; j <= n; j ++) {
		int mid = (i + j) / 2;
		dis[i][j] = (mid - i) * num[mid] - (sum[mid - 1] - sum[i - 1]);
		dis[i][j] += (sum[j] - sum[mid]) - (j - mid) * num[mid];

	    }
	}
	for (int i = 1; i <= n; i ++)
	    dp[1][i] = dis[1][i];
	for (int i = 2; i <= m; i ++) {
	    for (int j = 1; j <= n; j ++) {
		for (int k = i - 1; k < j; k ++) {
		    if (dp[i][j] > dp[i - 1][k] + dis[k + 1][j]) {
			dp[i][j] = dp[i - 1][k] + dis[k + 1][j];
			way[i][j] = k;
		    }
		}	    
	    }
	}
	printf("Chain %d\n", t ++);
	print(m, n);
	printf("Total distance sum = %d\n", dp[m][n]);
	printf("\n");
    }
    return 0;
}


你可能感兴趣的:(UVA 662 Fast Food(dp))