POJ 3253 Fence Repair(优先队列&哈夫曼树)

Fence Repair
http://poj.org/problem?id=3253

Time Limit:  2000MS
Memory Limit: 65536K

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer  N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make  N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


题意抽象:
有数列aN和其和SN( 1 ≤N  ≤ 20000,1 ≤ ai ≤ 50000)。
这里反着描述题目的操作,从aN中取两数,求和后放回原数列,一直这么做直到只剩下一个数,求这个数的最小值。

思路:
不用构造 哈夫曼树(也有音译成赫夫曼),但我们可以用构造哈夫曼树的思想:
假设有n个权值w1,w2,…,wn,则构造出的哈夫曼树有n个叶子结点。
Step:
(1) 将w1、w2、…,wn看成是有n 棵树的森林(每棵树仅有一个结点);
(2) 在森林中选出两个根结点的权值最小的树合并,作为一棵新树的左、右子树,且新树的根结点权值为其左、右子树根结点权值之和;
(3)从森林中删除选取的两棵树,并将新树加入森林;
(4)重复(2)、(3)步,直到森林中只剩一棵树为止,该树即为所求得的哈夫曼树。
这里我们用优先队列,每次取出两个最小的数,求和,再入队,直到队中只剩下一个元素,然后输出它。
注意:总花费是上限是14,361,600,000,超int(其他变量都在int范围内)。这里直接上__int64搞定。
复杂度:O(Nlog N)

完整代码:
/*16ms,356KB*/

#include <cstdio>
#include <queue>
#include <vector>
using namespace std;

int main()
{
	int n, t;
	__int64 sum;
	while (~scanf("%d", &n))
	{
		priority_queue<int, vector<int>, greater<int> > Q;//最小的数在队列最上面
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &t);
			Q.push(t);
		}
		//////////////////////////////////
		sum = 0;
		while (Q.size() > 1)
		{
			int a = Q.top();
			Q.pop();
			int b = Q.top();
			Q.pop();
			t = a + b;
			sum += t;
			Q.push(t);
		}
		printf("%I64d\n", sum);
	}
	return 0;
}


你可能感兴趣的:(ACM,优先队列,poj)