1009. Product of Polynomials (25)

http://www.patest.cn/contests/pat-a-practise/1009

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
#include <stdio.h>
typedef struct{//多项式中的一项
	int exp;
	float coe;
}NODE;
int main(){
	NODE poly1[10];
	NODE poly2[10];
	float A[2001] = {0.0};
	int n1,n2;
	int i,j;
	int tmp_exp;
	float tmp_coe;
	int cnt = 0;
	scanf("%d",&n1);
	for(i = 0;i < n1;++i){
		scanf("%d %f",&poly1[i].exp,&poly1[i].coe);
	}
	scanf("%d",&n2);
	for(i = 0;i < n2;++i){
		scanf("%d %f",&poly2[i].exp,&poly2[i].coe);
	}
	for(i = 0;i < n1;++i){
		for(j = 0;j < n2;++j){
			tmp_exp = poly1[i].exp + poly2[j].exp;
			tmp_coe = poly1[i].coe * poly2[j].coe;
			if(A[tmp_exp] == 0) cnt++;
			A[tmp_exp] = A[tmp_exp] + tmp_coe;
			if(A[tmp_exp] == 0) cnt--; //之前没有这句话,导致一个case没有过
		}
	}
	printf("%d",cnt);
	for(i = 2000;i >= 0;--i){
		if(A[i] != 0)
			printf(" %d %.1f",i,A[i]);
	}
	return 0;
}


你可能感兴趣的:(算法,解题报告,pat,1009)