1671字典树

http://acm.hdu.edu.cn/showproblem.php?pid=1671

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10588    Accepted Submission(s): 3662


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. 
Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as
 you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, 
the number of phone numbers, on a separate line, 1 <= n <= 10000. 
Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
   
   
   
   
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
   
   
   
   
NO YES



#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef struct ac //节点结构体
{
	int v;
	struct ac *child[11];
}tree;

tree *root; //头节点,不存任何值
int flag; 
void add(char *p)
{
	int i,j,l=strlen(p);
	tree *a=root,*b;

	for(i=0;i<l;i++)   //每个单词占一层
	{
		int k=p[i]-'0';

		if(a->child[k]!=0)
		{
			a=a->child[k];   
			if(a->v==1) // 遍历到一个前缀 			{
				flag=1;
				break;
			}
		}
		else
		{
			b=(tree *)malloc(sizeof(tree));
			for(j=0;j<=9;j++)
				b->child[j]=0;
			a->child[k]=b;
			a=b;
		}
	}
	a->v=1;				//每个单词最后一位标记为1.

	for(i=0;i<=9;i++)//若该单词最后一位存在下一个节点与之相连,则该单词为前缀
	{
		if(a->child[i]!=0)
		{
			flag=1;
			return ;
		}
	}
}

void clear(tree * p)	//释放内存,该题无此函数mle
{
	if(p==NULL)
		return ;
	else
	{
		for(int i=0;i<=9;i++)
			clear(p->child[i]);
	}
	free(p);
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		flag=0;
		root=(tree *)malloc(sizeof(tree));
		int i,n;
		for(i=0;i<=9;i++)
			root->child[i]=0;
		root->v=0;

		char s[12];
		scanf("%d",&n);
	
		for(i=1;i<=n;i++)
		{
			scanf("%s",s);
			add(s);
		}
		if(flag)
			printf("NO\n");
		else
			printf("YES\n");
		clear(root);
	}
	return 0;
}

你可能感兴趣的:(字典树)