HDU 5349 MZL's simple problem (STL 优先队列)

Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number  N  ( N106 ),representing the number of operations.
Next  N  line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than  109 .
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
   
   
   
   
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
   
   
   
   
3 4
 
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<cstdio>
using namespace std;
priority_queue<int,vector<int>,greater<int> >qq;
int main()
{
    int n,mmax;
    int a,b;
    while(scanf("%d",&n)!=EOF){
        mmax=-2147483647;
        while(!qq.empty()) qq.pop();
        while(n--){
            scanf("%d",&a);
            if(a==1){
                scanf("%d",&b);
                if(qq.empty()) mmax=-2147483647;
                qq.push(b);
                mmax=max(mmax,b);
            }
            if(a==2){
                if(!qq.empty()) {
                    qq.pop();
                }
                else mmax=-2147483647;
            }
            if(a==3){
                if(!qq.empty()){
                    printf("%d\n",mmax);
                }
                else {
                    printf("0\n");
                }
            }
        }
    }
    return 0;
    
}


你可能感兴趣的:(HDU 5349 MZL's simple problem (STL 优先队列))