POJ 2299 Ultra-QuickSort

树状数组求逆序对,需要离散化。。

Ultra-QuickSort

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence


9 1 0 5 4 ,

Ultra-QuickSort produces the output

0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define ll long long
#define prt(k) cout<<#k"="<<k<<" ";
#define N 1000050
int lowbit(int x) {return x&-x; }

struct node
{
    int v,ord;
}s[N];
bool cmp(node a,node b) { return a.v<b.v; }
int a[N],c[N];
int n;
void add(int p,int x)
{
    for(int i=p;i<=n;i+=lowbit(i)) c[i]+=x;
}
ll sum(int p)
{
    ll ret=0;
    for(int i=p;i>0;i-=lowbit(i)) ret+=c[i];//,prt(i);
    return ret;
}
#include<algorithm>
int main()
{
    while(cin>>n&&n)
    {
      for(int i=1;i<=n;i++)
    {
        scanf("%d",&s[i].v);
        s[i].ord=i;
    }
    sort(s+1,s+n+1,cmp);
    for(int i=1;i<=n;i++) a[s[i].ord]=i;
    memset(c,0,sizeof c);

    ll ans=0;
    for(int i=1;i<=n;i++)
    {
        add(a[i],1);
        ans+=i-sum(a[i]);
    }
    cout<<ans<<endl;
    }
}


你可能感兴趣的:(C++,ACM,poj,DFS,离散化)