POJ 2385 Lake Counting (dfs_连通性)

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3



#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,m;
char map[111][111];
void dfs(int i,int j)
{
	if(i>n||i<1||j>m||j<1) return;
	if(map[i][j]=='.') return ;
	map[i][j]='.';
	dfs(i,j+1);
	dfs(i+1,j+1);
	dfs(i+1,j);
	dfs(i+1,j-1);
	dfs(i,j-1);
	dfs(i-1,j-1);
	dfs(i-1,j);
	dfs(i-1,j+1);
}

int main()
{
	int i,j,ans;
	while(cin>>n>>m) {
		for(i=1;i<=n;i++) {
			for(j=1;j<=m;j++)
			cin>>map[i][j];
		}
		ans=0;
		for(i=1;i<=n;i++) {
			for(j=1;j<=m;j++){
				if(map[i][j]=='W') {
					ans++;
					dfs(i,j);
				}
			}
		}
		cout<<ans<<endl;
	}
	return 0;
} 



你可能感兴趣的:(POJ 2385 Lake Counting (dfs_连通性))