POJ 3984 迷宫问题 (DFS+BFS)

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
using namespace std;
typedef pair<int,int> node;
int m[6][6],s[6][6],ok;
node ans[111];
int dx[4]={0,1,0,-1},dy[4]={1,0,-1,0};
stack<node>ss;
void bfs()
{
	queue<node>qq;
	qq.push(node(0,0));
	while(!qq.empty()) {
		node t=qq.front();
		qq.pop();
		for(int i=0;i<4;i++) {
			int x=dx[i]+t.first;
			int y=dy[i]+t.second;
			if(x>4||x<0||y>4||y<0||m[x][y]==1) continue;
			if(s[t.first][t.second]+1<s[x][y]) {
				s[x][y]=s[t.first][t.second]+1;
				qq.push(node(x,y));
			}
		}
	}
}
void dfs(int x,int y)
{
	if(x==0&&y==0) {
		ok=1;
		return;
	}
	if(ok) return;
	for(int i=0;i<4;i++) {
		int tx=x+dx[i];
		int ty=y+dy[i];
		if(tx>4||tx<0||ty>4||ty<0) continue;
		if(s[x][y]==s[tx][ty]+1) {
			ss.push(node(tx,ty));
			dfs(tx,ty);
		}
	}
}

int main()
{
	int i,j;
	for(i=0;i<5;i++) {
		for(j=0;j<5;j++){
			cin>>m[i][j];
			s[i][j]=100;
		}
	}
	s[0][0]=0;
	bfs();
	ok=0;
	ss.push(node(4,4));
	dfs(4,4);
	while(!ss.empty()) {
		node t=ss.top();
		ss.pop();
		printf("(%d, %d)\n",t.first,t.second);
	}
	return 0;
} 





你可能感兴趣的:(POJ 3984 迷宫问题 (DFS+BFS))